PDA

Visualizza Versione Completa : configurare ffdshow audio



animale81
01-04-2007, 10:19
C'è una guida bellissima come si trovano sempre quà per configurare l'audio con ffdshow?

DMD
01-04-2007, 13:19
Tasto magico "Search" ;)

Bye

animale81
01-04-2007, 13:48
ho cercato ma che parla di settaggi audio non ho trovato niente,.,.,,., o almeno non ho visto niente....

Mike5
01-04-2007, 18:03
Se leggi questo (http://www.avmagazine.it/forum/showthread.php?t=39901) thread e riassumi i settaggi principali, ottieni una piccola guida.

Michele

DMD
02-04-2007, 07:21
Inoltre se vuoi farti un'idea, tra l'altro già suggerita, se vuoi dare uno sguardo al mio setting alla voce Post Processing audio: http://www.avmagazine.it/forum/showpost.php?p=483049&postcount=56

Ciao

animale81
02-04-2007, 19:30
grazie.....

DMD
02-04-2007, 20:36
Prova anche qui: http://www.theatertek.com/Forums/showthread.php?t=9823

Ciao
Domenico

sebi
28-04-2007, 09:13
Prova anche qui: http://www.theatertek.com/Forums/showthread.php?t=9823


Ho letto il tuo "tutorial" sul forum di Theatertek e anche il resto.

Tuttavia non mi riesce, dopo numerosi tentativi, di demandare a ffdshow la decodifica dolby digital per l'uscita analogica multicanale dalla scheda audio durante la riproduzione di DVD.

L'impressione è che il decoder audio interno al software (Nvidia) non si lasci by-passare da ffdshow audio che in effetti non si attiva.

Ho seguito scrupolosamente la procedura come da te indicato ma senza risultati.

Ho tentato peraltro di "forzare" il decoder audio in Thethertek da registro di sistema ma nulla.

Sbaglio qualcosa o come dire siamo in un "cul de sac"? :D

Grazie sebi

ciuchino
28-04-2007, 09:57
L'impressione è che il decoder audio interno al software (Nvidia) non si lasci by-passare da ffdshow audio che in effetti non si attiva.

Per i DVD devi "sostituire" l'intera catena dei filtri per cambiare decoder audio.
Domenico ha fatto esempi qui' :
http://www.avmagazine.it/forum/showthread.php?t=55752&highlight=graph

Comunque a quanto dicono "sembra" che suoni meglio la decodifica fatta da Nvidia ... se hai il pacchetto avanzato audio di TT.

Ciao
Antonio

animale81
28-04-2007, 10:44
teoricamente quaindi dovremmo usare tutto nvidia sia audio che video.....e con reclock immagino....

ciuchino
28-04-2007, 10:49
Il programma di default fornisce/usa quelli.
Per altri decoder o addendum tipo Ffdshow e reclock ognuno deve valutare in proprio.
Per i DVD uso Spdif ed Nvidia audio a me' non da' problemi.

animale81
28-04-2007, 11:02
quindi forse tanto per smanettare un pò si potrebbe fare 2 o 3 catene di codec e provarli per testare le differenze ... se ce ne sono, perchè ho paura che non sempre riesco a vedewrle queste differenze.
Ma se io faccio uno screenshot del filmato quand utilizzo un codec e poi faccio lo stesso con un altro, se osservo le due foto li posso vederla la differenza oppure con uno screenshot sparisce tutto?

sebi
28-04-2007, 13:16
Per i DVD devi "sostituire" l'intera catena dei filtri per cambiare decoder audio.

Grazie per la risposta intanto:)

Immaginavo della modifica con GraphEdit ma avevo pensato di starci lontano per un pò (tra l'altro non l'ho mai usato) perchè già è un periodo in cui sono sovraccarico di "smanettamenti" :cry:


Comunque a quanto dicono "sembra" che suoni meglio la decodifica fatta da Nvidia ... se hai il pacchetto avanzato audio di TT.

Non ce l'ho...l'avevo usato con la versione trial ed in effetti andava bene.

Quindi a parte comprarlo o usare GraphEdit non ci sono soluzioni alternative per scavalcare il decoder Nvidia?

fanoI
05-05-2007, 01:11
Non mi funziona!!!

Ho un file avi con con audio AC3 a 44 KHz e forse per qualche strana incompatibilità` con la scheda audio settando spdif come uscita (pass-trough) non si sente nulla...
Invece con i normali AC3 a 48 KHz tutto funziona bene...

Seguendo questa guida ho settato il resampling a 48, ma ahime senza alcun risultato... l'unico modo in cui funziona e` mettendo liba52 invece di spdif, ma cosi` mi sa che faccio una doppia conversione in Ac3 e l'Ac3 io preferirei mantenerlo intoccato se possibile :cry:

Ho provato pure con Ac3filter, ma con quello i risultati erano ridocoli: se non altro usciva a 44 KHz, ma poi l'audio era velocizzato... tipo chipmunks :eek:

La cosa strana e` che mi sa che prima di formattare per passare a Xp sta cosa funzionava pure... chissà` cos'è` che interferisce adesso :mad: :mad: :mad:

Grazie per l'aiuto,
fanoI

DMD
04-09-2007, 12:34
Fino alla versione ffdshow_rev1381_20070729 ffdshow audio funziona in modo corretto ottenendo sull'out spdif, lo stream digitale.
Ma dalle release successive questo non succede, eppure il setting è lo stesso.

Questi sono gli screen in sequenza (basta cliccare per ingrandire): http://img178.imageshack.us/img178/7229/settingffdshowaudioij0.jpg

A riprova di questo, è che il "monitor level" del volume mi viene correttamente visualizzato.
Cosa può impedire il corretto trasferimento alle uscite spdif dello stream digitale? :muro:

Cordialmente ringrazio
Domenico

ciuchino
04-09-2007, 12:40
Non vedo il settaggio output

DMD
04-09-2007, 12:57
Scusatemi! Eccolo!

http://img104.imageshack.us/img104/92/screenoutlz4.jpg (http://imageshack.us)

ciuchino
04-09-2007, 13:04
Sembra corretto.
Hanno aggiunto un paio di opzioni ... non so' schiaccia a caso se no' sara' buggata :)

DMD
04-09-2007, 13:19
Una si ma tre versioni successive, mi sembrano troppe.
In particolar modo ho provato le release 1431,1437 e 1443.

Ciao
Domenico

ciuchino
04-09-2007, 13:46
Ma il DD e il DTS dai DVD passa ?
Il problema ce l'hai solo quando deve fare encoding , non so' con un MOV apple , oppure con tutto ?
Se fai un graph si connette al renderer audio ed hai ancora il problema mandando in play quello ?

DMD
04-09-2007, 23:14
Dal lato DVD tutto OK (sia dts che DD), non uso ffdshow audio, solo con i graph dove è inserito (mov, mkv, ts etc..), anche se faccio un graph nuovo all'istante si connette regolarmente al renderer audio.
Comunque se disinstallo le ultime release e reinstallo la versione rev1381_20070729_clsid ritorna tutto ok!.
E' questo che non capisco :muro:

DMD
04-09-2007, 23:21
Antonio ho posto la questione anche qui: http://ffdshow-tryout.sourceforge.net/phpBB2/viewtopic.php?t=488
puoi darmi una mano a capirci qualcosa?

Grazie

ciuchino
04-09-2007, 23:30
Per adesso ti hanno risposto di provare a spuntare "Maximize SPDIF compatibility" che "ripristina" la vecchia struttura Spdif.
Il problema sembra non solo tuo per quello e' stata messa quell'opzione.
Il resto e' una discussione loro su dove mettere quell'opzione ... sarebbe meglio nella codec page dicono ma non c'e' posto.

In pratica schiaccia a caso come ti avevo gia' detto ... scherzo ;)

Ciao :)

YGPMOLE
04-09-2007, 23:53
Domenico, prova a mettere il flag su "Mixer", impostando "3+2 canali" ed il flag anche su LFE.

DMD
05-09-2007, 00:11
Ho risolto a metà , ossia nella versione dove è presente la selezione "Maximize SPDIF compatibility" è tutto OK! nelle versioni in cui questa opzione manca non funziona lo stream digitale.
http://ffdshow-tryout.sourceforge.net/phpBB2/viewtopic.php?p=1824#1824

Comunque domani proverò anche con la sezione "Mixer".

Grazie ancora a tutti. ;) :ronf:

p.s. @YGPMOLE ma cosi non si riprocessa lo stream digitale?:what:

YGPMOLE
05-09-2007, 00:20
@YGPMOLE ma cosi non si riprocessa ancora di più lo stream digitale?:what:

Non dovrebbe: avendo lasciato l'impostazione di veicolare i flussi AC3 e DTS via S/PDIF, la sezione Mixer interviene solo con i segnali che non sono nativamente in quei formati, e li ricodifica in 5+1 canali AC3 a 640bit.

In questo modo, ad esempio, il WMA diventa AC3 5+1 canali e si può fare a meno di AC3Filter!!!

E comunque anch'io uso la rev1381_20070729_clsid, con cui funziona tutto!!!

DMD
05-09-2007, 07:25
Questo mi confermi che è l'ultima verisione prima di quelle "buggate" tranne le release con la casellina "Maximize SPDIF compatibility".
Comunque a questo punto spero che rilasciano versioni corrette anche per le release clsid_sse_icl10

Comunque mi pare che confermano anche qui: http://forum.doom9.org/showpost.php?p=1041559&postcount=1898

ciuchino
05-09-2007, 09:41
Domenico non farmeli arrabbiare troppo :D
Chiaro che essendo release quasi giornaliere la successiva corregge la precedente se ha creato un problema.
Mi sembra che stanno aggiungendo altre cosette e' questo ha creato un problema di compatibilita' sulla Spdif con alcuni ampli.
Il fatto e' di per se positivo perche' gli utenti le testano e riportano i problemi in diretta.

Ciao :)

DMD
05-09-2007, 09:44
beh! comunque penso di avergli fatto anche da cavia ehm!... scusa da tester, al fine di migliorare le successive release.

Ciao
Domenico :)

ciuchino
05-09-2007, 09:47
Guarda che agli sviluppatori fa' solo piacere se gli riporti la tua esperienza ed i problemi che hai trovato.
Figurati che per certi software che paghi manco si degnano di risponderti.

DMD
17-10-2007, 14:48
FINALMENTE HO RISOLTO!!! :winner:

L'assenza di segnale sulla SPDIF, con le nuove release di ffdshow.
occorre selezionare "Maximize SPDIF compatibility" nella sezione "Codecs", per rendere compatibile queste nuove versioni con gli ingressi SPDIF degli amply HT.
E che comunque anche l'autore dice che è stato inserito questo nuovo comando nella sezione Codecs, in quanto di default ha dei problemi.

"...One more thing, the most important one : on the new releases I added a new SPDIF management which is not perfect because it does not work on some HT receivers. So I added a checkbox to enable the old behaviour : in AC3 format in the codec section, check "Maximize SPDIF compatibility..."

Qui riepilogo il setting per il multicanale via SPDIF: http://img141.imageshack.us/img141/5783/settingmq6.jpg

Un saluto
Domenico

wubix
09-12-2007, 09:19
Ciao,
la mia configurazione era già così, ma con alcuni film in AC3 o non sento niente, o l'audio è completamente distorto.
Per ovviare al problema in "output" invece che spuntare "ac3" devo spuntare "32bit"
dove sbaglio?
un saluto

W

mamach
11-02-2008, 08:41
[B][SIZE="3"]
Qui riepilogo il setting per il multicanale via SPDIF: http://img141.imageshack.us/img141/5783/settingmq6.jpg


ciao, stavo riguardando il tuo riepilogo e volevo chiederti alcune cose:
1) perchè la sezione "mixer" non l'hai configurata?
2) perchè le sezioni equalizzatore e ritardo non le hai configurate (non servono)??
3) se anzichè un impianto 5.1 si usa un impianto 3.1, in windows (tua prima immagine) come si deve settare?

ciao e grazie
massimo

DMD
11-02-2008, 09:29
...1) perchè la sezione "mixer" non l'hai configurata?...
Perchè non ritengo necessario "reincoderare" lo stream digitale, lo mando liscio così comè all'amply decoder. D'altronde se noti, nella sezione Codecs, sia la voce DTS che AC3 sono impostate su S/PDIF


...2) perchè le sezioni equalizzatore e ritardo non le hai configurate (non servono)??...
Dipende, io non le ritengo necessarie, e poi avendo impostato i codec come sopra, queste funzioni vengono bypassate.


...3) se anzichè un impianto 5.1 si usa un impianto 3.1, in windows (tua prima immagine) come si deve settare?...
Questa modalità non l'ho mai provata, però penso se non sono segnali stereo surround, puoi selezionare tranquillamente la prima impostazione multicanale di windows.

Un saluto
Domenico

mamach
11-02-2008, 10:05
Perchè non ritengo necessario "reincoderare" lo stream digitale, lo mando liscio così comè all'amply decoder. D'altronde se noti, nella sezione Codecs, sia la voce DTS che AC3 sono impostate su S/PDIF


anch'io dovrei mandare il flusso audio all'amply.
Quindi non è necessario dire a ffdshow di che sistema si dispone (sezione mixer) per esempio 3/0/2 + LFE, 3/0/0 + LFE, e così via?

Un'altra domanda, nella configurazione dei driver della sk audio bisogna impostare l'uscita S/PDIF (e disabilitare quella analogica??) a 48KHz? o 96KHz?

DMD
11-02-2008, 12:22
...
Quindi non è necessario dire a ffdshow di che sistema si dispone (sezione mixer) per esempio 3/0/2 + LFE, 3/0/0 + LFE, e così via?...
Affermativo, se vedi gli screen queste voci non le ho toccate.


...della sk audio bisogna impostare l'uscita S/PDIF (e disabilitare quella analogica??) a 48KHz? o 96KHz?
Lascerei su auto, questa funzione per la Prodigy 7.1 c'è, in quanto se capita di ascoltare CD o altri formati audio codificati a 44,1KHz la scheda si regola da sola, altrimenti rischi di sentire cose strane.

mamach
11-02-2008, 14:31
Lascerei su auto,

mi sa che sulla mia (Theatron Agrippa che poi non è altro che la Auzentech X-Plosion 7.1 DTS rimarcata) l'impostazione auto non c'è.
Comunque per la musica uso Mediaportal + driver ASIO che se non sbagliano ricampionano a 48KHz.
Per cui penso di dover settare la S/PDIF a 48KHz.

Ti ringrazio tanto.
ciao

YGPMOLE
12-02-2008, 06:11
Perchè non ritengo necessario "reincoderare" lo stream digitale, lo mando liscio così comè all'amply decoder. D'altronde se noti, nella sezione Codecs, sia la voce DTS che AC3 sono impostate su S/PDIF

Però il settaggio 3/0/2 + LFE può essere utile quando si decide di ascoltare le tracce WMA, ad esempio, in modo che vengano trascodificate in DD 5+1 ed ascoltate su tutti i diffusori come se fossero native in Doby Digital.

Questo, ovviamente, per chi non ha una scheda audio come quella di mamach che esegue la decodifica in hardware...

DMD
12-02-2008, 07:43
Questo è vero, però le impostazioni rimangono anche per il flusso nativo 5.1, per cui cosa succederebbe con questi segnali, un re-riprocessamento?

Un saluto

mamach
12-02-2008, 22:29
Lascerei su auto, questa funzione per la Prodigy 7.1 c'è, in quanto se capita di ascoltare CD o altri formati audio codificati a 44,1KHz la scheda si regola da sola, altrimenti rischi di sentire cose strane.

scusa sarò de coccio, ma tu quale opzione sceglieresti tra queste disponibili per "non toccare" il flusso audio e mandarlo "puro" all'amplificatore?
8036

DMD
13-02-2008, 05:36
Prova a settare su 48KHz, poi per i CD dovrebbe ricampionare il flusso :rolleyes:

M3m3nt0
11-12-2008, 23:07
rispolvero questo topic per un problema che mi affligge da tempo e davvero non so più che pesci pigliare!!

ho seguito la "guida" qui proposta e devo dire che adesso riesco a far passare il flusso audio tramite la spdif e farlo arrivare alle casse (z5500) che hanno il loro decodificatore...
detto ciò però l'audio dei DVD (Dolby o DTS che sia) si sente molto basso nei canali posteriori usando Media Player Classic mentre usando PowerDVD 8 si sente molto bene da tutti i canali.

il mio quesito è questo: powerdvd funziona con codec suoi, giusto?
quindi la questione del volume basso dipende da ffshow??

altra cosa, avete un test da proporre per verificare il corretto settaggio del Dolby e del DTS?(oltre alla prova coi DVD)

grazie mille dell'aiuto!

Cappella
28-12-2009, 12:04
Qualcuno potrebbe aggiornare la situazione dei settaggi idonea per la nuova versione di ffdshow audio contenuto nel nuovo pacchetto K-lite codec 5.5.6? Intendo ovviamente per ottimizzare al massimo l'audio inviato da spdif ad un sintoamplificatore. Grazie!

Cappella
20-03-2010, 13:14
E' passato parecchio tempo ed intanto sono arrivato alla 5.8.3. Comunque rinnovo la domanda.

GrandeBoma
25-03-2010, 11:42
Forse non interesserà a molti, ma segnalo che ffdshow audio decoder può funzionare in accoppiata con arcsoft audio decoder HD. A cosa serve? ad avere la decodifica del dts hd in pcm e allo stesso tempo poter usare tutte le funzioni di ffdshow audio agenti sul pcm decodificato. Per fare così è necessario che nella lista filtri siano settati entrambi i decoder (in ordine) arcsoft e ffdshow (prefer entrambi) e in ffdshow nella sezione "codec" selezionare attivare la voce "uncompressed" (all)

Credo inoltre che sia necessario usare arcsoft mpeg demux come splitter

a me è servito tantissimo, spero anche a voi

ovviamente questo trucco dovrebbe funzionare sia per bitstreaming che per analogico, per chi magari ha un ampli dotato di hdmi ma senza codifiche e vuole il dts hd ma in pcm con mpc-hc

Cappella
05-12-2010, 13:04
Interessante!!! Spero potrai aiutarmi a risolvere un problema molto antipatico: io utilizzo il KmPlayer con ffdshow ed ogni volta che mando avanti un filmato mi scompare dal sintoamplificatore l'info sulla codifica (es.: DTS o Dolby Digital) e devo sempre aspettare un pò che riagganci l'audio e quindi che ricomparga la scritta DTS o ecc..., mentre intanto il video va avanti e mi perdo qualche parola. Il fatto è che provando ad esempio col player Vlc questo non accade, quindi deduco che il problema viene dalla gestione di ffdshow ed i suoi setting. Potresti aiutarmi a rivedere le impostazioni della sezione output o altro? Grazie! :)

p.s.: se qualcuno conosce la soluzione al mio problema, si faccia avanti!

GrandeBoma
06-12-2010, 09:53
non saprei come risolvere il tuo problema, perchè io uso l'analogico quindi non ho modo per testare un problema di bitstreaming

Cappella
06-12-2010, 13:12
Bhe, :( grazie lo stesso; spero che qualcuno mi possa aiutare. Ho fatto innumerevoli prove, ma niente. La cosa strana è che se nella schermata output tolgo la spunta su: "AC3 (S/PDIF encode mode)", non mi parte neanche il filmato e si blocca il player. Forse dipende anche da qualche impostazione audio del player. :rolleyes:

GrandeBoma
06-12-2010, 13:18
se hai messo spdif encode vuol dire che il player sta decodificando e poi ricodificando l'audio, non va bene

sei sicuro che hai impostato ffdshow per emettere l'audio sulla spdif correttamente?

Mike5
06-12-2010, 13:28
Se vuoi passare il bitstream compresso sulla S/PDIF o HDMI, nella schermata output du ffdshow audio devi spuntare la casella relativa al formato in Pass-through (S/PDIF, HDMI) e in quella codecs devi impostare il formato a "disabled".

Cappella
06-12-2010, 21:26
...e in quella codecs devi impostare il formato a "disabled".
Cosa intendi per formato, devo disabilitare tutte le voci riguardanti le codifiche audio più note? Intanto vi comunico che oggi è avvenuto "il miracolo"! Cioè sono riuscito a risolvere il mio problema; ho fatto una ricerca in rete ed ho trovato questa utile discussione: http://www.avmagazine.it/forum/archive/index.php/t-145592-p-2.html che mi ha portato ad installare il driver audio Realtek ATI HDMI Audio Device R2.55, il quale adesso riesce a non farmi più sganciare l'audio dal sintoamplificatore. :D Non abbandonatemi però, percchè voglio perfezionare i setting audio. Grazie!

Cappella
06-12-2010, 21:53
Mike5, saresti così gentile da dare un'occhiata alle seguenti immaggini e dirmi se c'è qualcosa di errato nei setting?
http://img826.imageshack.us/img826/7113/immagine01.png
http://img163.imageshack.us/img163/1736/immagine02.png
http://img713.imageshack.us/img713/1477/immagine03l.png
http://img3.imageshack.us/img3/3858/immagine04.png
Secondo me la chiave per una perfetta gestione del mio impianto, sta tutta quì. Tieni conto che con questi setting, se disattivo l'AC3 encode mode su output di ffdshow, non mi parte più neanche il filmato. Vorrei sottolineare il fatto che così funziona tutto correttamente, ma se mi si dice che è errata la spunta su AC3 encode mode, vuol dire che si può perfezionare ulteriormente. Voglio essere sicuro di avere la massima qualità possibile e che tutto lavori correttamente e che arrivi l'audio più diretto possibile al sinto in modo da non stravolgere la codifica originale con inutili processamenti che possono fare perdere qualità.

Mike5
07-12-2010, 08:47
Con queste impostazioni credo che ffdshow prima decodifichi il formato compresso in PCM, poi applichi tutte le elaborazioni che hai selezionato (Volume, Mixer, etc...), poi lo ricodifichi di nuovo in DD (AC3).

Se è questo quello che vuoi, va bene. L'alternativa è mandare direttamente il formato compresso alla S/PDIF/HDMI, con una migliore tenuta della qualità, visto che il segnale non viene decodificato e poi ricodificato di nuovo e nel caso del DTS non viene tradotto da DTS a DD. Però con quest'altra configurazione non vengono applicate tutte le elaborazioni, perchè ffdshow non tocca il formato compresso. Scegli tu.

Per scegliere tra le due opzioni bisogna andare nella schermata codecs, che è 3 righe sopra Area di notifica (tray) nella mia versione e abilitare (libavcodec o liba52) o disabilitare (disabled) la decodifica del formato che ti interessa, formato per formato (AC3, DTS, ...). Se abiliti segue il percorso decodifica, elaborazione, ricodifica -> S/PDIF, se non abiliti manda quello che c'è nell'audio della sorgente direttamente alla S/PDIF.

Anche se nella schermata output di ffdshow sono spuntate le caselle del pass-through, se in output arriva un PCM decodificato, queste caselle sono ininfluenti. Per ottenere il pass-through devi assicurarti che in output arrivi il formato compresso non toccato. Ffdshow è complicato e la traduzione italiana non aiuta (infatti lo uso in inglese). Nella schermata output "Formati di campionamento output supportati" quello che ho detto sopra non si capisce, ma nella versione inglese "Output formats for uncompressed or decoded streams" fa intuire che se l'output è non compresso (PCM) si applicano le caselle sotto e non quelle sopra.

Per le schermate KMP non so dirti nulla perchè non lo conosco.

Cappella
07-12-2010, 08:58
..."Output formats for uncompressed or decoded streams" fa intuire che se l'output è non compresso (PCM) si applicano le caselle sotto e non quelle sopra. Per le schermate KMP non so dirti nulla perchè non lo conosco.
:rolleyes: E' o non è compresso? :confused: E proprio questo il "guaio", cioè quello che non conosci il Km. Il problema non è quello che voglio io, ma capire qual'è la cosa più giusta per ottenere il miglior risultato. Quindi, ho capito che per mandare il segnale in uscita più diretto possibile, bisogna disabilitare le codifiche interessate alla voce output. Ora la problematica è appunto riuscire a capire come configurare al meglio Km per inviare il giusto segnale passante direttamente a ffdshow. Cercherò di fare altre prove, anche se già ne ho fatte non sò quante! Anche se non conosci il Km, per una questione di logica, cosa ne pensi della terza immaggine? Cosa dovrei cambiare? Del tipo: io spunterei......

Mike5
07-12-2010, 09:41
Se usi ffdshow il decoder interno di KMP deve essere solo escluso, non so da dove si esclude perchè non conosco KMP. Una volta escluso, le opzioni di KMP non dovrebbero avere più importanza, solo quelle di ffdshow.

Mi viene un dubbio. Hai verificato che ffdshow entra nel grafo? Cioè che è lui a trattare l'audio? Non so come si fa a verificare in KMP.

Cappella
07-12-2010, 11:16
Certo, quando lancio un flmato mi compare l'icona di ffdshow audio sulla barra degli strumenti. Ho provato e niente! Appena disabilito le codifiche non mi riconosce più la codifica audio e ho notato che non parte nemmeno l'ffdshow. Per la cronaca, anche se ho messo la lingua italiana su ffdshow, il pacchetto K-lite è il 640+pacchetto integrativo. Nella seguente immagine, trovi qualcosa di errato sulle info? http://img819.imageshack.us/img819/8241/immagine05.png

Cappella
08-12-2010, 15:59
Un piccolo passo avanti: Installando la verione 1439 del Km (avevo la 1438), adesso riesco a farlo funzionare con l'opzione AC3 encode mode disabilitata. Ora resta da risolvere il fatto che disabilitando le codifiche interessate su codec (ffdshow), l'ampli non mi aggancia più le codifiche. :rolleyes: Ancora non riesco a dare in pasto a ffd, l'audio corretto in uscita dal KM. :confused: :(

Cappella
10-12-2010, 21:55
Mike5, in attesa di una risposta, ti comunico che mi sono convertito dopo tanto tempo ed ho deciso di abbandonare il Km e passare a Mpc sfruttando la DXVA. Adesso forse potrai aiutarmi meglio con l'audio. Disabilitanto le codifiche su Codec supportati come suggerivi tu, ffdshow audio non entra più in funzione ed è assente dalla barra degli strumenti. :rolleyes: :confused: Inoltre con mpc ho problemi con l'aac sia che gestito da ffdshow, che dal solo player; l'amplificatore anzichè ricevere un segnale come se fosse analogico, dovrebbe trattare ad esempio un aac 2ch come segnale digitale 2ch stereo e far funzionare il PrologicII (che virtualizza il 5.1), mediante il quale si sente decisamente meglio. Mentre invece adesso non è più così com'era quando usavo i filtri interni del KMP per gestire l'aac.

Mike5
18-12-2010, 17:09
Non so come aiutarti perchè c'è qualcosa che imposti male da qualche parte, ma è difficile dire dove senza vedere e fare qualche prova. ffdshow è complicato e anch'io mi incasino a volte e ho necessità di fare alcune prove per capire dove sbaglio.

Cappella
18-12-2010, 23:28
Ma non c'è una guida da seguire passo passo in rete per poter controllare i miei setting? Comunque partendo dalle impostazioni di default, non dovrebbe essere difficile visto che non si deve intervenire in molti setting. Mi confermi che player usi? Non ricordo; magari dipende anche da esso. Comunque per funzionare funziona, a parte l'aac che non mi piace. Quindi finchè non si disattivano i codec supportati, l'audio non è proprio diretto? :confused: con dts e dd tenendo la freccetta del desktop sul logo ffdshow nella barra degli strumenti, mi da dts o dd bitstream ed output spdif e a seguire un numero tra parentesi tipo spdif (1401) o qualcosa del genere. L'aac invece mi da output pcm 5.1. :rolleyes:

mamach
21-12-2010, 15:34
Domanda n.1
chi mi sa dire quali sono le differenze nella sezione mixer di ffdshow audio tra:

1) SAME AS INPUT
2) 5.1 (3/0/2 + LFE)
3) DISABLE

Mi sembra di non notare differenze :rolleyes:

Impostazioni che uso:
- Win7 32bit
- uscita analogica 5.1 (integrata nella mobo). Non so perchè ma l'analogico mi ha sempre affascinato di più rispetto alle uscite digitali
- ffdshow: codec uncompressed=all supported / mixer=same as imput??? / output 16bit/24bit E NULLA PIU'

Domanda n.2
esempio, metto un DVD con audio DD5.1. Eè normale che in uscita (analogica) ffdshow mostri "PCM 5.1 48000Hz 16bit"?

In realtà avrei una raffica di domande, ma credo che aprirò un'altro topic ;)

ciuchino
21-12-2010, 16:34
Same as input mantiene lo stesso numero/configurazioni canali come da file sorgente.

Le altre opzioni sono forzature a secondo del sistema che hai o che vuoi ottenere.
Certo che se a un due canali non applichi elaborazioni esce sempre in stereo anche se hai settato 5.1.

Il DD (come il DTS) dopo decodifica (quindi stai decodificando con Ffdshow) e' un PCM 48000Hz 16bit , per cui e' giusto.
Sei ancora nel mondo digitale , chi ti porta nel mondo analogico sono i DAC (convertitore digitale/analogico) della tua scheda audio.

mamach
21-12-2010, 17:00
ciao ciuchino, piacere di risentirti :)
chiaro come al solito, ma una conferma te la chiedo ugualmente:

Certo che se a un due canali non applichi elaborazioni esce sempre in stereo anche se hai settato 5.1.

quindi se ho ben capito: stavo vedendo un film con audio MONO (non recentissimo :D ), non ho applicato elaborazioni, per cui è per questo che impostando "same as imput" o "5.1" la solfa non cambia?


PS: quando farò il bombardamento spero tu mi dia qualche risposta ;)

ciuchino
21-12-2010, 17:09
Certo se non fai nente ti dovrebbe andare sul canale centrale in ogni caso se e' mono.

Un caso inverso molto usato e' se puoi sentire solo in stereo (una TV per esempio).
Allora setti 2.0 e tutto verra' downmixato su due canali ... se no con il 5.1 ti perdi centrale ed il resto.

PS: io ormai sono amante del bitstream , quei lavori li faccio fare all'ampli.
Per cui non so molto di elaborazioni Ffdshow varie ;)

Cappella
21-12-2010, 23:36
Io con le nuove recentissime configurazioni, ho capito che la migliore cosa su Mixer è proprio Same as input; adesso infatti (come riuscivo a fare con Kmplayer. Adesso uso Mpc-hc) se ho un film con audio in mp3 2ch stereo, riesco a far arrivare 2ch stereo digitali all'ampli, così da poter sfruttare il modo d'ascolto PLII Movie, che virtualizza un 5.1 col parlato al centro. Questo però è possibile, così come anche il riconoscimento degli aac 6ch o 5.1, spuntando l'AC3 Encode mode alla voce output di ffshow audio decoder. Quindi in questo caso mi riconosce aac 6ch come Dolby Digital 5.1; mentre se ho un aac 2ch stereo 41000Hz, all'ampli arriva un segnale stereo analogico e più esattamente e stranamente in output da pcm 5.1. Approfitto per chiedere a Ciuchino se è regolare l'informazinone visualizzata tenedo la frecetta del desktop sopra l'icona blu di ffdshow presente sulla barra degli strumenti quando il filtro è in funzone: in pratica se la fonte è ad esempio DD 5.1 mi dà "Input: Dolby Digital 5.1, 48000 HZ ...kbps (bitstream). Output: S/PDIF (1400). Questo significa che è tutto regolare a dimostrazione che setting vanno bene? Spero di si! Ma che significa questo (1400) che a volte [forse con DTS] mi da (1401) e con gli mp3 se non sbaglio (900)? :rolleyes: :confused:

ciuchino
22-12-2010, 08:41
Se segnala spdif vuol dire che fai bitstream di quel flusso , per cui vedi se l'ampli lo accetta correttamente.
Comunque se non ricordo male e' normale che con DD sia 1400 e DTS 1401 , ma non so cosa significhi esattamente.
Potrebbe essere il "tipo" di connessione con il renderer audio .. comunque basta che funzioni :)
Bisognerebbe fare la domanda agli sviluppatori.

Cappella
22-12-2010, 10:32
Se segnala spdif vuol dire che fai bitstream di quel flusso , per cui vedi se l'ampli lo accetta correttamente.

Nel senso se il segnale è dd l'ampli lo deve agganciare come dd, se dts come dts e così via? Se intendi questo, allora sono apposto!

p.s.: ma per non avere problemi con Win7 64bit, è meglio avere mpc+ffdshow versione per 32 bit (x86), oppure x64?

YGPMOLE
22-12-2010, 17:32
ma per non avere problemi con Win7 64bit, è meglio avere mpc+ffdshow versione per 32 bit (x86), oppure x64?

La catena di filtri in uso deve essere TUTTA della stessa tipologia, per funzionare: se non usi ReClock (di cui non esiste una versione a 64Bit - e gli sviluppatori mi hanno risposto che non esisterà nell'immediato futuro), potresti utilizzare tutti software x64 che, in teoria, dovrebbero essere più prestazionali ed ottimizzati.

Al contrario, se utilizzi ReClock, anche gli altri software dovranno essere necessariamente x86.

Cappella
22-12-2010, 17:52
Grazie! Infatti sto provando Reclok e sto seguendo questa guida complessa ma molto completa: http://www.homecinema-hd.com/intro_en.html Il problema è che dai primi collaudi l'ampli non mi aggancia le codifiche e mi da sempre segnale analogico stereo. :rolleyes: